PEPPLER.ORG
Michael Peppler
Sybase Consulting
Menu
Home
Sybase on Linux
Install Guide for Sybase on Linux
General Sybase Resources
General Perl Resources
Freeware
Sybperl
Sybase::Simple
DBD::Sybase
BCP Tool
Bug Tracker
Mailing List Archive
Downloads Directory
FAQs
Sybase on Linux FAQ
Sybperl FAQ
Personal
Michael Peppler's resume

sybperl-l Archive

Up    Prev    Next    

From: "Julian Thomas" <jthomas at globeop dot com>
Subject: RE: Problem wit loading CTLib via CGI on WinXp
Date: Feb 4 2009 9:09AM

Any ideas

________________________________

From: owner-sybperl-l@peppler.org [mailto:owner-sybperl-l@peppler.org]
On Behalf Of Julian Thomas
Sent: 18 December 2008 12:08
To: sybperl-l@peppler.org
Subject: Problem wit loading CTLib via CGI on WinXp


Hi 
 
The scripts work perfectly when run via  acommand prompt or through an
IDE
But when I try to run them via Apache2.2 I get the following errors.
 

Software error:

Can't load 'D:/perl.5.8.8/site/lib/auto/Sybase/CTlib/CTlib.dll' for
module Sybase::CTlib: load_file:The specified module could not be found
at D:/perl.5.8.8/lib/DynaLoader.pm line 229.
 at D:/Apps/Apache2.2/cgi-bin/simple.cgi line 20
Compilation failed in require at D:/Apps/Apache2.2/cgi-bin/simple.cgi
line 20.
BEGIN failed--compilation aborted at
D:/Apps/Apache2.2/cgi-bin/simple.cgi line 20.

if i print the Environment out before the use Sybase::CTLib call I get
COMSPEC= C:\WINDOWS\system32\cmd.exe

DOCUMENT_ROOT= D:/Apps/Apache2.2/htdocs

GATEWAY_INTERFACE= CGI/1.1

HTTP_ACCEPT= */*

HTTP_ACCEPT_ENCODING= gzip, deflate

HTTP_ACCEPT_LANGUAGE= en-gb

HTTP_CONNECTION= Keep-Alive

HTTP_HOST= ldn1dpc383.globeop.com

HTTP_UA_CPU= x86

HTTP_USER_AGENT= Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET
CLR 2.0.50727; .NET CLR 3.0.04506.30; InfoPath.1; .NET CLR
3.0.04506.648)

LD_LIBRARY_PATH= Z:\Apps\sybase\OCS-12_5\dll

LIB= Z:\Apps\sybase\OCS-12_5\lib

PATH=
D:\Perl.5.8.8\bin;D:\Perl.5.8.8\site\bin;D:\Perl.5.8.8\bin;z:\Apps\sybas
e\odbc\ODBC;C:\Program Files\ActiveState Komodo Edit
4.2\;C:\Python25\;D:\Perl\bin;z:\Apps\sybase\OCS-12_5\lib3p;z:\Apps\syba
se\OCS-12_5\dll;z:\Apps\sybase\OCS-12_5\bin;C:\WINDOWS\system32;C:\WINDO
WS;C:\WINDOWS\System32\Wbem

PATHEXT= .COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.py;.pyw

QUERY_STRING= 

REMOTE_ADDR= 172.27.40.242

REMOTE_PORT= 3595

REQUEST_METHOD= GET

REQUEST_URI= /cgi-bin/printenv.cgi

SCRIPT_FILENAME= D:/Apps/Apache2.2/cgi-bin/printenv.cgi

SCRIPT_NAME= /cgi-bin/printenv.cgi

SERVER_ADDR= 172.27.40.242

SERVER_ADMIN= jthomas@globeop.com

SERVER_NAME= ldn1dpc383.globeop.com

SERVER_PORT= 80

SERVER_PROTOCOL= HTTP/1.1

SERVER_SIGNATURE= 

SERVER_SOFTWARE= Apache/2.2.10 (Win32)

SYBASE= Z:\Apps\sybase

SYBASE_JRE= Z:\Apps\sybase\shared-1_0\JRE-1_3

SYBASE_OCS= OCS-12_5

SYSTEMROOT= C:\WINDOWS

WINDIR= C:\WINDOWS

Now this used to work so somthing has changed.
 
I attach the http.conf file
 
Any help would be appreciated
 
Rgds
 
Julian
 
 
 
________________________________

This email with all information contained herein or attached hereto may
contain confidential and/or privileged information intended for the
addressee(s) only. If you have received this email in error, please
contact the sender and immediately delete this email in its entirety and
any attachments thereto.
(H1)
 

--------------------------------------------------------------------------
This email with all information contained herein or attached hereto may contain confidential and/or privileged information intended for the addressee(s) only. If you have received this email in error, please contact the sender and immediately delete this email in its entirety and any attachments thereto.
(H1)