PEPPLER.ORG
Michael Peppler
Sybase Consulting
Menu
Home
Sybase on Linux
Install Guide for Sybase on Linux
General Sybase Resources
General Perl Resources
Freeware
Sybperl
Sybase::Simple
DBD::Sybase
BCP Tool
Bug Tracker
Mailing List Archive
Downloads Directory
FAQs
Sybase on Linux FAQ
Sybperl FAQ
Personal
Michael Peppler's resume

sybperl-l Archive

Up    Prev    Next    

From: Michael Peppler <mpeppler at peppler dot org>
Subject: Re: CTlib problem
Date: Dec 29 2003 10:34PM

On Mon, 2003-12-29 at 14:02, McCarthy, John wrote:
> We have developed a CGI app that works fine on our dev web machine, but when we try to run it on our production web site, we get the following errors:
> 
> The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are: 
> Can't load 'C:/Perl/site/lib/auto/Sybase/CTlib/CTlib.dll' for module Sybase::CTlib: load_file:The specified module could not be found at C:/Perl/lib/DynaLoader.pm line 229.
>  at C:/Perl/site/lib/Sybase/Simple.pm line 19
> Compilation failed in require at C:/Perl/site/lib/Sybase/Simple.pm line 19.
> BEGIN failed--compilation aborted at C:/Perl/site/lib/Sybase/Simple.pm line 19.

Have you verified that the Sybase::CTlib module is correctly installed
on your production machine?

If it is, are the Sybase libraries installed correctly?

Are there any other differences between the production and development
machines?

Michael
-- 
Michael Peppler                              Data Migrations, Inc.
mpeppler@peppler.org                 http://www.mbay.net/~mpeppler
Sybase T-SQL/OpenClient/OpenServer/C/Perl developer available for short or 
long term contract positions - http://www.mbay.net/~mpeppler/resume.html