PEPPLER.ORG
Michael Peppler
Sybase Consulting
Menu
Home
Sybase on Linux
Install Guide for Sybase on Linux
General Sybase Resources
General Perl Resources
Freeware
Sybperl
Sybase::Simple
DBD::Sybase
BCP Tool
Bug Tracker
Mailing List Archive
Downloads Directory
FAQs
Sybase on Linux FAQ
Sybperl FAQ
Personal
Michael Peppler's resume

sybperl-l Archive

Up    Prev    Next    

From: ye wei <yw at alabanza dot net>
Subject: Re: "undefined symbol: scl_init " again!
Date: May 8 2000 5:44PM

Michael Peppler wrote:

> ye wei writes:
>  > Hi,
>  >
>  > I remembered when I first installed sybperl, I got "unefined symbol:
>  > scl_init" error, then
>  > I fixed it by modifying CONFIG file, and setting up sybase environment.
>  > But yesterday
>  > when I tried to install sybperl on my laptop computer, I got it once
>  > again, even after I setup
>  > 'CONFIG', 'PWD' file and environment variables. I tried to build with
>  > dynamic and static link libct.so,
>  > but both failed at last.
>  >
>  > This is the screenshot when I tried to build with dynamic link libct.so,
>  > after I have run 'make install'.
>  >
>  > My computer are installed with Redhat6.1, kernel upgraded to 2.2.14,
>  > sybase-11.9.2-linux, sybperl-2.11 and perl 5.005_3.
>
> You need to make sure that you link with -lsybtcl not -ltcl. Normally
> the Makefile.PL script does this automatically, but it appears that in
> your case it didn't - so edit CTlib/Makefile and change -ltcl to
> -lsybtcl and rebuild sybperl.

Machael,

After I did as what you said, everything goes very perfectly!!! :)
Maybe it's nessary to put above instructions into the FAQ!

Thanks very very much!!


>
>
> Michael
> --
> Michael Peppler         -||-  Data Migrations Inc.
> mpeppler@peppler.org    -||-  http://www.mbay.net/~mpeppler
> Int. Sybase User Group  -||-  http://www.isug.com
> Sybase on Linux mailing list: ase-linux-list@isug.com

--

Sincerely,

Ye wei