PEPPLER.ORG
Michael Peppler
Sybase Consulting
Menu
Home
Sybase on Linux
Install Guide for Sybase on Linux
General Sybase Resources
General Perl Resources
Freeware
Sybperl
Sybase::Simple
DBD::Sybase
BCP Tool
Bug Tracker
Mailing List Archive
Downloads Directory
FAQs
Sybase on Linux FAQ
Sybperl FAQ
Personal
Michael Peppler's resume

sybperl-l Archive

Up    Prev    Next    

From: "Dan Page" <Dan dot Page at notes dot fairchildsemi dot com>
Subject: Re: CGI error
Date: Jul 29 1999 2:16PM


I tried setting this variable before the use Sybase::DBlib statement and still
got the error; Do I need to get the web admin involved to set it there. We're
using Netscape Enterprise server.








Michael Peppler  on 07/27/99 02:42:46 PM

Please respond to SYBPERL-L@listproc.net
                                                                                
                                                                                
                                                                                


                                                              
                                                              
                                                              
 To:      SybPerl Discussion List     
                                                              
 cc:      (bcc: Dan Page/SouthPortland/Fairchild)             
                                                              
                                                              
                                                              
 Subject: Re: CGI error                                       
                                                              








Dan Page writes:
 >
 >
 > using Sybase::DBlib &  Perl5.002
 > I am getting the following error in my browser
 > at /usr/local/lib/perl5/Sybase/DBlib.pm line 304 BEGIN failed--compilation
 > aborted at /home/dpage/cgi-bin/test.cgi line 4.
 >
 > line 4  is use Sybase::Dblib;
 >
 > the program runs find from the command line

You probably need to have LD_LIBRARY_PATH set before your CGI script
starts.

If you are using Apache, you can set it in the httpd.conf file:

     SetEnv LD_LIBRARY_PATH /opt/sybase/lib   # or whatever

Michael
--
Michael Peppler         -||-  Data Migrations Inc.
mpeppler@peppler.org    -||-  http://www.mbay.net/~mpeppler
Int. Sybase User Group  -||-  http://www.isug.com
Sybase on Linux mailing list: ase-linux-list@isug.com