PEPPLER.ORG
Michael Peppler
Sybase Consulting
Menu
Home
Sybase on Linux
Install Guide for Sybase on Linux
General Sybase Resources
General Perl Resources
Freeware
Sybperl
Sybase::Simple
DBD::Sybase
BCP Tool
Bug Tracker
Mailing List Archive
Downloads Directory
FAQs
Sybase on Linux FAQ
Sybperl FAQ
Personal
Michael Peppler's resume

sybperl-l Archive

Up    Prev    Next    

From: Zion_Huang at focusppo dot com
Subject: Re: ct_init() error, looking for ctlib.loc
Date: May 18 1999 8:25PM

Monty:

I had recently upgraded a sybase server from 11.0.2 to 11.0.3.3.

And after the upgraded, the ./lib directory was missing too.

I called sybase and they told me that I have to manually copy them from
/opt/sybase1102/lib to the /opt/sybase1103/lib
because the upgrade program does not migrate the ./lib sub-directoy.   They
also told me that CTlib was not changed from 11.0.2 to 11.0.3.3.


Zion





Monty Scroggins  on 05/18/99 01:40:29 PM

Please respond to SYBPERL-L@listproc.net

To:   SybPerl Discussion List 
cc:    (bcc: Zion Huang/Brntwood/Focus/Concentra)
Subject:  Re: ct_init() error, looking for ctlib.loc




No it wasnt..  It was 11.5.1     We noticed the problem after an
update was applied to the server.   The update that was applied
changed the isql and bcp binaries to be ct-lib based (among other
things)...  It was when the isql binary was executed that we got
the error about the ctlib.loc file missing...   Oddly enough, it could
not be found in  the server, and had to manually copied from another
(older) one...

-----Original Message-----
From: Michael Peppler 
To: SybPerl Discussion List 
Date: Tuesday, May 18, 1999 12:18 PM
Subject: Re: ct_init() error, looking for ctlib.loc


>Monty Scroggins writes:
> > We had the same problem.  It appears to happen when a brand
> > new server is built.  The ctlib.loc file had to be located on
> > another (older version) server and copied to the new one.  All
> > was well after that.  I never figured out why the ctlib.loc file
> > was not in place.  I am assuming there is an installation problem
> > with Sybase....
>
>Was that an 11.9.x server that you installed?
>
>Michael
>
>
> >
> > Michael Peppler wrote:
> > >
> > > Robert Bresner writes:
> > >  > the $SYBASE env var is correct. It's what's _after_ the
> > >  > /usr/local/sybase that's wrong.
> > >  >    locales/us_english/iso_1/ctlib.loc
> > >  > should be
> > >  >    locales/us_english/ctlib.loc
> > >
> > > Not on any Sybase installation that I've ever seen (at least System
10
> > > and later):
> > >
> > > I have a Solaris 10.x, 11.0.3 and 11.5, as well as linux 11.0.3.3,
and
> > > all have locales/us_english/iso_1/ctlib.loc.
> > >
> > > Methinks your installation is broken.
> > >
> > > Michael
> > > --
> > > Michael Peppler         -||-  Data Migrations Inc.
> > > mpeppler@peppler.org    -||-  http://www.mbay.net/~mpeppler
> > > Int. Sybase User Group  -||-  http://www.isug.com
> > > Sybase on Linux mailing list: ase-linux-list@isug.com
> >
> > --
> > /_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/
> > Monty Scroggins  MCI Incorporated
> > Monty.Scroggins@wcom.com
> >
> >  Those are my principles....
> >  if you dont like them I have others..
> >  -Groucho Marx
> >
>
>--
>Michael Peppler         -||-  Data Migrations Inc.
>mpeppler@peppler.org    -||-  http://www.mbay.net/~mpeppler
>Int. Sybase User Group  -||-  http://www.isug.com
>Sybase on Linux mailing list: ase-linux-list@isug.com
>