PEPPLER.ORG
Michael Peppler
Sybase Consulting
Menu
Home
Sybase on Linux
Install Guide for Sybase on Linux
General Sybase Resources
General Perl Resources
Freeware
Sybperl
Sybase::Simple
DBD::Sybase
BCP Tool
Bug Tracker
Mailing List Archive
Downloads Directory
FAQs
Sybase on Linux FAQ
Sybperl FAQ
Personal
Michael Peppler's resume

sybperl-l Archive

Up    Prev    Next    

From: Michael Peppler <mpeppler at peppler dot org>
Subject: FW: CTlib Error Hangs Script
Date: Apr 6 1999 11:55PM

Ellery, Michael BGI SF writes:
 > 
 > I just wanted to share this with the list -- the solution to my CTlib
 > problem was to install a newer OpenClient (11.1.1, I think...).  No more
 > nasty scripts that blow-up.

A bug in OpenClient... well well well... fancy that!

:-)

Michael


 > > -----Original Message-----
 > > From:	Michael Peppler [SMTP:mpeppler@peppler.org]
 > > Sent:	Tuesday, March 23, 1999 6:38 PM
 > > To:	SybPerl Discussion List
 > > Subject:	CTlib Error Hangs Script
 > > 
 > > Ellery, Michael BGI SF writes:
 > >  > 
 > >  > I posted something about this problem a few days ago.  Since that time,
 > > I
 > >  > have put together a test script that verifies (I think..) my problem.
 > > The
 > >  > basic problem is this--a certain error message causes my scripts to
 > > blow-up.
 > >  > Exactly where, when, or if they blow up is totally unpredictable, but
 > > the
 > >  > blow-up is always preceded by one or more occurrences of the following
 > >  > errors:
 > >  > 
 > >  > ---------------------------------------------------------------
 > >  > Open Client Message:  (In msg_cb)
 > >  > Message Number: LAYER = 5  ORIGIN = 3 
 > >  >                 SEVERITY = 4  NUMBER = 2 
 > >  > Message String:  ct_connect(): network packet layer: internal net
 > > library
 > >  > error: Attempt to use invalid address handle
 > >  > ---------------------------------------------------------------
 > >  > 
 > >  > Here is the test script that I put together -- it basically loops 100
 > > times
 > >  > and tries to set-up 5 simultaneous connections (note that the
 > > user/passwd
 > >  > have been commented out).
 > > 
 > > I've tried this script here (Solaris 7, OC 11.1.1, perl 5.005_02) and
 > > it works fine.
 > > I've also run it on linux (OC 10.0.3, perl 5.005_02) and that works
 > > fine too, so I suspect a problem with either perl 5.004_04, or more
 > > probably a problem with the Sybase networking libraries on the HP-UX
 > > platform. 
 > > 
 > > Michael
 > > -- 
 > > Michael Peppler         -||-  Data Migrations Inc.
 > > mpeppler@peppler.org    -||-  http://www.mbay.net/~mpeppler
 > > Int. Sybase User Group  -||-  http://www.isug.com
 > > Sybase on Linux mailing list: ase-linux-list@isug.com
 > 

-- 
Michael Peppler         -||-  Data Migrations Inc.
mpeppler@peppler.org    -||-  http://www.mbay.net/~mpeppler
Int. Sybase User Group  -||-  http://www.isug.com
Sybase on Linux mailing list: ase-linux-list@isug.com