PEPPLER.ORG
Michael Peppler
Sybase Consulting
Menu
Home
Sybase on Linux
Install Guide for Sybase on Linux
General Sybase Resources
General Perl Resources
Freeware
Sybperl
Sybase::Simple
DBD::Sybase
BCP Tool
Bug Tracker
Mailing List Archive
Downloads Directory
FAQs
Sybase on Linux FAQ
Sybperl FAQ
Personal
Michael Peppler's resume

sybperl-l Archive

Up    Prev    Next    

From: Michael Peppler <mpeppler at peppler dot org>
Subject: Re: 'make test' fails with "Server name not found..."
Date: Oct 22 1999 9:18PM

Dan Chetlin writes:
 > I apologize if this is a dumb question or off-topic.  I've searched numerous
 > FAQs and list archives for the answer, to no avail.  The search mechanism for
 > this list's archives seems to be out of order, but skimming the recent topics
 > makes me think that I'm not posting a redundant question.
 > 
 > I've downloaded and 'rpm'-d ASE 11.0.3.3, and set up the interfaces file (a
 > dump of which is included at the bottom of this message).  I'm running RedHat
 > 6.0 with perl 5.005_03.  I got Sybperl 2.11 from CPAN and (with $SYBASE set
 > to where the ASE libs are) set it up basically with its default
 > configurations.  Running 'make' works fine, but 'make test' returns this:
 > 
 > -----
 > 
 > PERL_DL_NONLAZY=1 /usr/bin/perl -I../blib/arch -I../blib/lib
 > -I/usr/lib/perl5/5.00503/i386-linux -I/usr/lib/perl5/5.00503 -e 'use
 > Test::Harness qw(&runtests $verbose); $verbose=0; runtests @ARGV;' t/*t
 > t/bcp....................Sybase error: Server name not found in interface
 > file.

YOur interfaces file is almost certainly OK.
However, did you set SRV to either ISE or STELLA in sybperl's PWD file 
before running make test?

Michael
-- 
Michael Peppler         -||-  Data Migrations Inc.
mpeppler@peppler.org    -||-  http://www.mbay.net/~mpeppler
Int. Sybase User Group  -||-  http://www.isug.com
Sybase on Linux mailing list: ase-linux-list@isug.com