PEPPLER.ORG
Michael Peppler
Sybase Consulting
Menu
Home
Sybase on Linux
Install Guide for Sybase on Linux
General Sybase Resources
General Perl Resources
Freeware
Sybperl
Sybase::Simple
DBD::Sybase
BCP Tool
Bug Tracker
Mailing List Archive
Downloads Directory
FAQs
Sybase on Linux FAQ
Sybperl FAQ
Personal
Michael Peppler's resume

sybperl-l Archive

Up    Prev    Next    

From: nathan at webdesigngroup dot com
Subject: RE: CGI with Apache and Sybperl on Red Hat 5.0/5.1
Date: Jun 8 1998 8:35PM

Hello,

Thanks for everyone's help on this, but one of the email replies I've
received (not posted to the list) confirmed what I suspected, that it is
RedHat's use of glibc that is causing the problem.  I was going to try web
servers other than Apache, but apparently that approach has been tried
before and does not work.  Looks like the only option is to back off to
RH4.2 for the time being.  At least until Sybase release a new version of
ctlib for linux compiled with glibc (if it happens at all).  Again, thanks
for all of your help.

Regards,

Nathan Harper

-----Original Message-----
From: owner-SYBPERL-L@listproc.net
[mailto:owner-SYBPERL-L@listproc.net]On Behalf Of
John_Erjavec@cargill.com
Sent: Monday, June 08, 1998 3:04 PM
To: SybPerl Discussion List
Cc: SYBPERL-L@listproc.net
Subject: Re: CGI with Apache and Sybperl on Red Hat 5.0/5.1


     This isn't a Sybase problem or a SybPerl problem, it is a CGI
     problem.  When you are outputting the headers, it is receiving a
     premature ending.  If you post the relevant parts of the code,
     someone might be able to help you here, but a better place to look
     would be someplace like comp.infosystems.www.cgi (I think that is the
     whole path), or, if you are interested in a mailing list, you could
     check out the HTML Writer's Guild at http://www.hwg.org .  Two of
     their mailing lists (-languages and -servers) would have people able
     to help you out in this situation.  HTH.

     -JEV
     John Erjavec V


______________________________ Reply Separator
_________________________________
Subject: CGI with Apache and Sybperl on Red Hat 5.0/5.1
Author:  nathan (nathan@webdesigngroup.com) at mtka-unix-mime
Date:    6/8/98 11:54 AM


Hi,

I have built sybperl successfully on a Redhat 5.0 and 5.1 machine, but have
encountered the same problem using it with Apache in both cases. Here are
the specifics:

- perl 5.004_04
- sybperl 2.09_04
- dynamically linked ctlib distribution
- Apache 1.2.6 and 1.3.0

Although building sybperl statically failed in every case that I tried,
building it dynamically was successful in that I could run scripts from the
command line without any problem.  However, when I tried to get CGI scripts
with Apache to run, they fail with a server error every time.  The error log
shows the generic 'premature end of script headers' error.  I don't think
that it is an environment variable problem or a problem with the interfaces
file.  I've set the SYBASE environment var. explicitly with the SetEnv
directive, I've tried using the more verbose error logging that Apache 1.3.0
provides, but it gives me nothing more helpful than the above error message.
The interfaces file that I'm using works fine with scripts run from the
command line, and with other Red Hat machines running 4.2. I'm thinking that
it is some sort of incompatibility between Apache and sybperl resulting from
the new glibc that Red Hat 5+ uses, but that is just a guess.

If anyone out there has any suggestions (other than downgrading to 4.2),
they would be greatly appreciated.  I will downgrade as a last resort, but
if anyone has had success with RedHat 5.x, Sybperl and any web server (not
just Apache), I'd like to hear about your experiences in order to help
narrow down the source of the problem.

Regards,

Nathan Harper

--
Web Design Group, Inc.
Ph: 312.951.6688
Fx: 312.951.6588
Email: nathan@webdesigngroup.com