PEPPLER.ORG
Michael Peppler
Sybase Consulting
Menu
Home
Sybase on Linux
Install Guide for Sybase on Linux
General Sybase Resources
General Perl Resources
Freeware
Sybperl
Sybase::Simple
DBD::Sybase
BCP Tool
Bug Tracker
Mailing List Archive
Downloads Directory
FAQs
Sybase on Linux FAQ
Sybperl FAQ
Personal
Michael Peppler's resume

sybperl-l Archive

Up    Prev    Next    

From: Hugh Caley <hcaley at tdl dot com>
Subject: Re: Simple SybPerl test fails
Date: Mar 9 1998 7:49PM

How about the extra libs statement in CONFIG?  Are you using anything besides
-linsck?

The example I've been using is the ct_sql example.

Hugh

Robb Canfield wrote:

> I have verified my CONFIG is correct (it has LINKTYPE=Static) and it
> appears to build properly, yet all attempts to use CTlib calls results in a
> "segmentation fault". I am sure it is something simple I am over looking
> but I can't seem to find it.  Has anyone verified that the example (or any
> SybPerl code) works under RedHat 5.0?
>
> At 07:58 AM 3/9/98 -0800, you wrote:
> >Robb Canfield wrote:
> >>
> >> After getting SybPerl to compile on RedHat I encountered a "segmentation
> >> fault" running one of the examples from Michael Peppler's web page:
> >>   http://www.mbay.net/~mpeppler/Sybperl/article.html
> >>
> >> It appears to run properly and then crashes. I of course altered the
> >> 'user', 'password' and "SERVER' entries from the example code. This is
> >> running on RedHat 5.0.
> >>
> >> Has anyone gotten this code to work, or is this example not valid?
> >
> >The example is valid.
> >
> >I fear it's your build of sybperl that has a problem (see my other
> >email on that).
> >
> >Michael
> >--
> >Michael Peppler         -||-  Data Migrations Inc.
> >mpeppler@datamig.com    -||-  http://www.mbay.net/~mpeppler
> >Int. Sybase User Group  -||-  http://www.isug.com
> >