PEPPLER.ORG
Michael Peppler
Sybase Consulting
Menu
Home
Sybase on Linux
Install Guide for Sybase on Linux
General Sybase Resources
General Perl Resources
Freeware
Sybperl
Sybase::Simple
DBD::Sybase
BCP Tool
Bug Tracker
Mailing List Archive
Downloads Directory
FAQs
Sybase on Linux FAQ
Sybperl FAQ
Personal
Michael Peppler's resume

sybperl-l Archive

Up    Prev    Next    

From: Scott Sutherland <sut92199 at ncs dot com>
Subject: Re: Trying to build 2.09 on WinNT, built ok but failed tests
Date: Feb 2 1998 10:23PM

On Fri, 30 Jan 1998, Todd E. Scheresky wrote:

> I HAVE NOT found anyone with the same configuration that will fess up to getting
> Sybperl 2.09 working on Windows NT.  I need CTlib!  So what I was thinking was
> that I would get Sybperl 2.08_52, apply the patches that Michael has suggested,
> and see if I can get it to build and test successfully.  What do you think
> Michael?
> 

I have the following configuration:

Win NT 4.0 (SP3)
VC 5.0 (No SP's)
PERL 5.004_04
Sybperl 2.09
Sybase 11.0.2


It worked 'out of the box' for me... The only changes that I made to the
distribution was the sybase library location varaible and the user name,
password, and server name in the PWD file... 

Here is the output from 'perl -V'

Summary of my perl5 (5.0 patchlevel 4 subversion 04) configuration:
  Platform:
    osname=MSWin32, osvers=4.0, archname=MSWin32
    uname=''
    hint=recommended, useposix=true, d_sigaction=undef
    bincompat3=undef useperlio=undef d_sfio=undef
  Compiler:
    cc='cl.exe', optimize='-O', gccversion=
    cppflags='-DWIN32'
    ccflags ='-MD -DWIN32'
    stdchar='unsigned char', d_stdstdio=define, usevfork=false
    voidflags=15, castflags=0, d_casti32=define, d_castneg=define
    intsize=4, alignbytes=8, usemymalloc=n, prototype=define
  Linker and Libraries:
    ld='link', ldflags ='-nologo -subsystem:windows'
    libpth=D:\win32app\DevStudio\VC\lib
    libs=oldnames.lib kernel32.lib user32.lib gdi32.lib  winspool.lib
comdlg32.lib advapi32.lib shell32.lib ole32.lib  oleaut32.lib netapi32.lib
uuid.lib wsock32.lib mpr.lib winmm.lib  version.lib odbc32.lib
odbccp32.lib
    libc=msvcrt.lib, so=dll
    useshrplib=undef, libperl=undef
  Dynamic Linking:
    dlsrc=dl_win32.xs, dlext=dll, d_dlsymun=undef, ccdlflags=' '
    cccdlflags='', lddlflags='-dll'


Characteristics of this binary (from libperl): 
  Compile-time options: DEBUGGING
  Built under MSWin32
  Compiled at Jan 16 1998 11:04:00
  @INC:
    d:\win32app\perl5.004\lib\site
    d:\win32app\perl5.004\lib
    D:\win32app\perl5.004\lib
    D:\win32app\perl5.004\lib\site
    D:\win32app\perl5.004\lib\site
    .


I know that 'It worked for me...' messages are about worthless...  Have
you tried to build the perl 5.004 binary from source with your version of
VC?

--
Scott Sutherland                          National Computer Systems
(319) 354-9200                        Measurement Services Division
                             Iowa City, Ia
#include "standard-disclaimer.h"