PEPPLER.ORG
Michael Peppler
Sybase Consulting
Menu
Home
Sybase on Linux
Install Guide for Sybase on Linux
General Sybase Resources
General Perl Resources
Freeware
Sybperl
Sybase::Simple
DBD::Sybase
BCP Tool
Bug Tracker
Mailing List Archive
Downloads Directory
FAQs
Sybase on Linux FAQ
Sybperl FAQ
Personal
Michael Peppler's resume

sybperl-l Archive

Up    Prev    Next    

From: Hugh Caley <hughc at lombard dot babcockbrown dot com>
Subject: Re: Problems with Sybperl and Linux
Date: Jan 28 1998 2:12AM

I'm also getting core dumps when I try to run a version of sqsh I compiled
myself, or the dynamically-linked precompiled version, although the
statically-linked version works OK.


Here's the output from gdb with the dynamic version of sqsh:

(gdb) run -Usa -SSFO
Starting program: /tmp/sqsh-1.6.dynamic/sqsh -Usa -SSFO

Program received signal SIGSEGV, Segmentation fault.
0x402105ca in rindex ()

(gdb) bt
#0  0x402105ca in rindex ()
#1  0x8097ca8 in ct__tds_rd_optioncmd ()
#2  0x8940ffff in ?? ()
Cannot access memory at address 0xfeff85b6.

Michael Peppler wrote:

> The test scripts are dumping core...
>
> Try this (in the sybperl source directory)
>
> ./perl -Mblib -MSybase::CTlib -e '$dbh = new Sybase::CTlib $user, $pwd,
> $server'
>
> (with appropriate values for $user, $pwd and $server, off course) and
> see what happens.
>
> If you get a core dump, use gdb to generate a back trace to see
> where you get the problem, and report back...
>
> Michael
>
> Hugh Caley wrote:
> >
> > I am attempted to build and run Sybperl on RedHat Linux 5.0 i386.
> > I have the CTlib libraries from Mr. Peppler's page, an interfaces file
> > from my local Sybase server.  The sybase directory is at /usr/sybase,
> > and I have the env varibles $SYBASE=/usr/sybase and $DSQUERY=SFO (SFO is
> >
> > the correct server name).
> >
> > I don't see any errors during perl Makefile.PL or make, but when I run
> > make test I get:
> >
> > PERL_DL_NONLAZY=1 ./../perl -I.././blib/arch -I.././blib/lib
> > -I/usr/lib/perl5/i386-linux/5.00401 -I/usr/lib/perl5 -e 'use
> > Test::Harness qw(&runtests $verbose); $verbose=0; runtests @ARGV;' t/*.t
> >
> > t/ctlib.............dubious
> >         Test returned status 0 (wstat 139)
> >         test program seems to have generated a core
> > t/cursor............dubious
> >         Test returned status 0 (wstat 139)
> > Undefined subroutine &Test::Harness::WCOREDUMP called at
> > /usr/lib/perl5/Test/Harness.pm line 219.
> > make[1]: *** [test_static] Error 139
> > make[1]: Leaving directory `/usr/src/sybperl-2.09/CTlib'
> > make: *** [test] Error 2
> >
> > Anyone know what error 139 is?  It doesn't seem to make any difference
> > what I have in the interfaces file; CONFIG is set to build only the
> > static CTlib, etc., per the documentation.  I have followed the
> > instructions for building the Linux version that were publised at Mr.
> > Peppler's site; however, I don't seem to have the problem he mentions
> > with the mis-named library (libtcl versus lsybtcl) so I never have to
> > change it.
> >
> > I appreciate any help I can get!
> >
> > --
> > Hugh Caley, System Administrator
> > Babcock & Brown, Inc., San Francisco
> > 1+512+1515x694 | hughc@babcockbrown.com
>
> --
> Michael Peppler       -||-  Data Migrations Inc.
> mpeppler@datamig.com  -||-  http://www.mbay.net/~mpeppler



--
Hugh Caley, System Administrator
Babcock & Brown, Inc., San Francisco
1+512+1515x694 | hughc@babcockbrown.com