PEPPLER.ORG
Michael Peppler
Sybase Consulting
Menu
Home
Sybase on Linux
Install Guide for Sybase on Linux
General Sybase Resources
General Perl Resources
Freeware
Sybperl
Sybase::Simple
DBD::Sybase
BCP Tool
Bug Tracker
Mailing List Archive
Downloads Directory
FAQs
Sybase on Linux FAQ
Sybperl FAQ
Personal
Michael Peppler's resume

sybperl-l Archive

Up    Prev    Next    

From: Laurent Sainte-Marthe <smarthe at genoscope dot cns dot fr>
Subject: RE: SUMMARY:Sybperl 2.08 in DU 4.0b
Date: Dec 19 1997 4:02PM

Good afternoon,

 I'm using OpenClient 11.1.1 and I met the same problem.
 It seems that the only fact to initialize LD_LIBRARY_PATH
 to the good sybase libraries path resolve loading of DBlib.so
 if LD_LIBRARY_PATH is not set, sybase libraries are not mapped
 during execution. (You can see with _RLD_ARGS=-v make test )
 
 But now, I have an other problem :
 
 during execution of a simple test
 
 use Sybase::DBlib;
 $user = "mylogin";
 $password = "mypassword";
 $server = "myserver";
 
 $dbh = new Sybase::DBlib $user, $password, $serveur;
 $dbh->dbcmd("use mydatabase");
 
 this message appear :
 
  Can't call method "dbcmd" without a package or object reference at ./test line 
12.
  
 
  Any idea is welcome
  
    Thanks
    
    Laurent
    
-------------------------------------------------------------
Laurent Sainte-Marthe			GENOSCOPE
Tel : 01-60-87-25-00		Centre National de Sequencage
Fax : 01-60-87-25-13
-------------------------------------------------------------

 
> 
> We've got 10.0.2 and 10.0.3 here; both had the same problem.
> 
> I've got 11.1 on order; I'll see what happens with that.
> 
> Steve
> >-----Original Message-----
> >From:	Harry Bochner [SMTP:harry.bochner@genomecorp.com]
> >Sent:	Tuesday, December 16, 1997 5:07 PM
> >To:	SYBPERL-L@trln.lib.unc.edu
> >Subject:	Re: SUMMARY:Sybperl 2.08 in DU 4.0b
> >
> >> >    cc -o lib$1.so -shared -expect_unresolved "*" -all lib$1.a
> >> 
> >> Maybe that's the trick. Are the OpenClient shared libs on DEC
> >> really broken???
> >
> >Not the OpenClient 11 shared libs. But I did notice they were
> >broken in one of the earlier versions. He was using 10.0.4, so
> >I guess that's the one ;-)
> >
> >-- 
> >Harry Bochner