PEPPLER.ORG
Michael Peppler
Sybase Consulting
Menu
Home
Sybase on Linux
Install Guide for Sybase on Linux
General Sybase Resources
General Perl Resources
Freeware
Sybperl
Sybase::Simple
DBD::Sybase
BCP Tool
Bug Tracker
Mailing List Archive
Downloads Directory
FAQs
Sybase on Linux FAQ
Sybperl FAQ
Personal
Michael Peppler's resume

sybperl-l Archive

Up    Prev    Next    

From: Michael Peppler <mpeppler at MBAY dot NET>
Subject: Re: Sybperl/html
Date: Nov 18 1997 11:19PM

Doug Robson wrote:
> 
> Hi all,
> maybe a newbie question
> 
> I am called a perl script denoted as .cgi ( which is allowed at my ISP ,
> and othere generaly work ).
> The web server is Solaris 2.6. Perl version 5.004, sybperl 2.08.
> 
> my question is that whilst if i hard code the user/password, etc into my
> perl script i can successfully login to a sybase 11 server, extract
> valid data, and generate the html output in the script to successfully
> redisplay back to my browser, If i try to use a form to post the values
> i see them going into the script thru debug but it causes a server side
> failure and generates a premature end of headers message in the
> error_log for httpd.
> 
> I wonder if it because of the post action i am somehow losing the scope
> of the request and then the httpd side has no where to send it..

If I understand you correctly - you can run the script from the command
line, but not in the browser, right?

That is usually an environment problem.

Make sure that $ENV{SYBASE} is set correctly.

Also - check httpd's error_log  - there's usually a clue there as
to what may be wrong.

Michael
-- 
Michael Peppler       -||-  Data Migrations Inc.
mpeppler@datamig.com  -||-  http://www.mbay.net/~mpeppler