PEPPLER.ORG
Michael Peppler
Sybase Consulting
Menu
Home
Sybase on Linux
Install Guide for Sybase on Linux
General Sybase Resources
General Perl Resources
Freeware
Sybperl
Sybase::Simple
DBD::Sybase
BCP Tool
Bug Tracker
Mailing List Archive
Downloads Directory
FAQs
Sybase on Linux FAQ
Sybperl FAQ
Personal
Michael Peppler's resume

sybperl-l Archive

Up    Prev    Next    

From: guerrier at Reston dot UnisysGSG dot COM (David Guerrieri - GTE)
Subject: Problem loading SybPerl
Date: Feb 9 1996 9:58PM

I am loading SybPerl 2.0 on a Sun Sparc5 running Solaris 2.5 with OpenClient
10.0.3 and Perl 5.001.  The installation seemed to go OK but when I ran the
make test it said:
cd CTlib ; make config INST_LIB=/opt2/local/src/sybperl/sybperl-2.0/blib 
INST_ARCHLIB=/opt2/local/src/sybperl/sybperl-2.0/blib  \
        INST_EXE=./blib LINKTYPE=dynamic LIBPERL_A=libperl.a 
cd DBlib ; make config INST_LIB=/opt2/local/src/sybperl/sybperl-2.0/blib 
INST_ARCHLIB=/opt2/local/src/sybperl/sybperl-2.0/blib  \
        INST_EXE=./blib LINKTYPE=dynamic LIBPERL_A=libperl.a 
cd Sybperl ; make config INST_LIB=/opt2/local/src/sybperl/sybperl-2.0/blib 
INST_ARCHLIB=/opt2/local/src/sybperl/sybperl-2.0/blib  \
        INST_EXE=./blib LINKTYPE=dynamic LIBPERL_A=libperl.a 
cd CTlib ; make all LINKTYPE=dynamic
cd DBlib ; make all LINKTYPE=dynamic
cd Sybperl ; make all LINKTYPE=dynamic
cd CTlib && test -f Makefile && make test LINKTYPE=dynamic
/usr/bin/perl -I/opt2/local/src/sybperl/sybperl-2.0/blib 
-I/opt2/local/src/sybperl/sybperl-2.0/blib -I/opt2/local/lib/perl5/sun4-solaris 
-I/opt2/local/lib/perl5 -e 'use Test::Harness qw(&runtests $verbose); 
$verbose=0; runtests @ARGV;' t/*.t
t/ctlib.............Can't load '/opt2/local/src/sybperl/sybperl-2.0/blib/auto/Sy
base/CTlib/CTlib.so' for module Sybase::CTlib: ld.so.1: /usr/bin/perl: fatal: 
libct.so: can't open file: errno=2 at /opt2/local/lib/perl5/DynaLoader.pm line 
128.
 
 at /opt2/local/src/sybperl/sybperl-2.0/blib/Sybase/CTlib.pm line 810
BEGIN failed--compilation aborted at t/ctlib.t line 8.
FAILED on test 0
Failed 1 test, 0.00% okay.
Files=0,  Tests=0,  1 secs ( 0.54 cusr  0.21 csys =  0.75 cpu)

Can you suggest where I might begin to look?

Dave