PEPPLER.ORG
Michael Peppler
Sybase Consulting
Menu
Home
Sybase on Linux
Install Guide for Sybase on Linux
General Sybase Resources
General Perl Resources
Freeware
Sybperl
Sybase::Simple
DBD::Sybase
BCP Tool
Bug Tracker
Mailing List Archive
Downloads Directory
FAQs
Sybase on Linux FAQ
Sybperl FAQ
Personal
Michael Peppler's resume

sybperl-l Archive

Up    Prev    Next    

From: Chayim Leib Weiss <kweiss at newscorp dot com>
Subject: sybperl 2.0 problem
Date: Jan 10 1996 6:34PM

I think I may have a clue....but I need to know where something is being picked up.

The path to .././blib/auto/Sybase/DBlib/DBlib.sl DBlib.o is not found ....
WHERE IS THE .. being picked up from...


Thanks,

email me at kweiss@newscorp.com

>Date: Wed, 10 Jan 96 16:36:19 +0100
>From: mpeppler@itf.CH (Michael Peppler)
>To: sybperl-l@trln.lib.unc.edu
>Subject: sybperl 2.0 problem
>Cc: kweiss@newscorp.com
>
>This fellow is having some problems building sybperl on HP-UX... as I
>don't have access to a HP-UX system, maybe someone on the list might
>understand what is going on...
>
>Michael
>----- Begin Included Message -----
>
>>From kweiss@newscorp.com  Tue Jan  9 20:08:56 1996
>X-Sender: kweiss@nyc-services
>X-Mailer: Windows Eudora Version 2.1.1
>Mime-Version: 1.0
>Content-Type: text/plain; charset="us-ascii"
>X-Priority: 1 (Highest)
>To: mpeppler@itf.ch (Michael Peppler)
>From: Chayim Leib Weiss 
>Subject: sybperl 2.0 problem
>X-Filter: mailagent [version 3.0 PL44] for mpeppler@itf.ch
>
>I am back on thi problem, would appreciate your help!!
>
>The version of perl is 5.001 - I was installed with the defaults in
>/usr/local/perl5
>
>I compiled and installed without insodent.
>Yes dynamic loading is enabled (static not available under HP-UX - I
>tried didn't compile).
>
>This is being done on HP-UX (O/S) 9.04
>
>WHen I compile sybperl it cannot find some libraries
>I fails on the linking.
>The version is sybperl 2.0 (I tried this before with the beta - 2.3b ) still the same problem
>
>LAST LINE BEFORE LIST OF UNSATISFIED SYBBOLS....
>
>LD_RUN_PATH="/sybase/lib"  ld -o .././blib/auto/Sybase/DBlib/DBlib.sl DBlib.o -L/sybase/lib -lsybdb -lm
>ld: Unsatisfied symbols:
>..
>..
>..
>..
>(list of 30 pls symbols)
>
>ANY IDEAS - I think you thought that I was compiling under "sun" before. I am
>unmde HP-UX as mentioned above...
>
>
>
>At 03:06 PM 10/24/95 +0100, you wrote:
>>> We purchased the compiler ($3100) and it was sucessfully
>>> installed 3 weeks ago...
>>> 
>>> I have been compiling stuff from the net and it all seems to work o.k.
>>> 
>>> Should I contact HP support
>>
>>Maybe. Though I really think that the problem lies with the
>>installation of Perl, rather than with the compiler.
>>
>>Which version of Perl do you have (run 'perl -v' to find out). When you
>>built perl (ie when you ran 'Configure') did you take all the defaults?
>>Is dynamic loading enabled?
>>
>>These are the questions that I think will determine what is wrong with
>>your installation...
>>
>>Michael

==========================================================
  All opinions, comments views are my own and may or may not be that  
 of my employer.                                                              
==========================================================
Chayim Leib Weiss -               MCI/NEWSCORP Internet Ventures 
Unix Systems Administrator   ----  Product Development Group                
620 Avenue Of The America's       6th Floor         N.Y., N.Y.       10011    
Phone - 212-462-5132   Fax -212-462-6944   beeper  --  800-396-4787
                                --------kweiss@newscorp.com--------
==========================================================